AIX LUN increase in 7 easy steps :)
1. Check rootvg disks:
# lsvg -p rootvg
2. Check bootlist:
# bootlist -m normal -o
3. For each disk do the following steps:
X and Y has to be replaced by correct numbers (for hdisk and dumplv)
a. Check LVs from one of the disks:
# lspv -l hdiskX
b. Unmirror the disk:
# unmirrorvg -c 1 rootvg hdiskX
c. Check remaining LVs on the disk:
# lspv -l hdiskX
- only dump LV should remain on the PV
- if there are onther LV's move them to the other disk:
# migratepv -l LVNAME hdiskX hdiskY
d. Deactivate the dumplv from this disk:
- view the current configuarion:
# sysdumpdev -l
- in case of primary dumplv is on this disk:
# sysdumpdev -P -p /dev/sysdumpnull
- in case of secondary dumplv is on this disk:
# sysdumpdev -P -s /dev/sysdumpnull
e. Remove the dumplv:
# rmlv lvdumpX
f. Remove hdisk from rootvg:
# reducevg rootvg hdiskX
g. Check disk size:
# bootinfo -s hdiskX
h. Integrate the disk back rootvg:
# extendvg rootvg hdiskX
i. Mirror rootvg (the syncking will be done in the background):
# mirrorvg -S -c 2 -m rootvg hdiskX
j. Verify that all LV's are synked:
# lsvg -l rootvg
- this operation could take a long time
- repeat this checking untill all LV's are open/syncd
- to force the sync of an LV you can use:
# syncvg -l lvname
k. Recreate the dump LV:
# mklv -t sysdump -u 1 -y lvdumpX rootvg 12 hdiskX
- size can be different depending on the estiomation:
# sysdumpdev -e
l. Enable dumplv:
# sysdumpdev -l
- in case of primary dumplv is on this disk:
# sysdumpdev -P -p /dev/dumplvX
- in case of secondary dumplv is on this disk:
# sysdumpdev -P -s /dev/dumplvX
m. Check that rootvg is fully mirrored ansd syncked:
# lsvg -l rootvg
4. Repeat steps 3 for the other disk
5. Correct bootlist like it was before:
# bootlist -m normal hdiskX hdiskY
6. Verify bootlist:
# bootlist -m normal -o
7. Rebuild bosboot to be sure:
# bosboot -a