To configure devices and installs device software in system:
root@gz~# cfgmgr
To configure the components connected to the vscsi0 interface:
root@gz~# cfgmgr -l vscsi0
To display config, diagnostics and vital product definition info:
root@gz~# lscfg
Display info about device mem0:
root@gz~# lscfg -l mem0
Display info about all Ethernet cards:
root@gz~# lscfg -l ent*
Display vpd:
root@gz~# lscfg -v
Display vpd of hdisk0:
root@gz~# lscfg -v -l hdisk0
How to display the PVID of a disk:
root@gz~# lquerypv -H /dev/hdisk0
To change device rmt0 from defined state to available state:
root@gz~# mkdev -l rmt0
To lists all supported devices:
root@gz~# lsdev -P
To list all supported disks:
root@gz~# lsdev -P -c disk
To display supported class:
root@gz~# lsdev -P -r class
To display all sub class:
root@gz~# lsdev -P -r subclass
To lists all configured devices:
root@gz~# lsdev -C
To display the properties of mem0:
root@gz~# lsdev -C -l mem0
To change default maxuproc value to 100:
root@gz~# chdev -l sys0 -a maxuproc=100
To change aio0 parameters (below AIX 6.1):
root@gz~# chdev -l aio0 -P -a minservers=150 -a maxservers=150
Note: modifications to aio0 require restart. If you try to modify them on the fly (without -P), you will get the following error:
root@gz~# chdev -l aio0 -a minservers=150 -a maxservers=150 Method error (/usr/lib/methods/chgaio): 0514-064 Cannot perform the requested function because the AIO kernel extension is permanent and cannot be unloaded.
To change the block size to 512:
root@gz~# chdev -l rmt0 -a blocksize=512
To avoid tape retension:
root@gz~# chdev -l rmt0 -a ret=no
To remove the device rmt0:
root@gz~# rmdev -l rmt0
To remove the device totally from database:
root@gz~# rmdev -d -l rmt0
Note: If an hdisk is removed with the rmdev -l hdiskx -d
command, then the hdisk name is available for use by another disk.
To change the state of the device stopped:
root@gz~# rmdev -l rmt0 -S
To display possible parent devices which accept rs232 devices:
root@gz~# lsparent -C -k rs232
To display parent devices which accept child device hdisk0:
root@gz~# lsparent -C -l hdisk0
To see the default values of the device rmt0:
root@gz~# lsattr -Dl rmt0
To see the current values of the device rmt0:
root@gz~# lsattr -El rmt0
To see all possible values of the login attribute of tty0:
root@gz~# lsattr -El tty0 -a login -R
To list all possible connection scsi0 can accept:
root@gz~# lsconn -p scsi0
To list the available major numbers:
root@gz~# lvlstmajor
How to create null device with major (2) and minor (2) nos. (c - char device):
root@gz~# mknod /dev/null c 2 2
How to check the sdd disk reservation:
root@gz~# lquerypr -Vh /dev/vpath0
How to check on which drawers you have the pci devices:
root@gz~# lsslot -c pci # Slot Description Device(s) U5602.003.9480047-P1-C8 PCI-E capable, Rev 1 slot with 8x lanes fcs0 fcs1 U5602.003.9480047-P1-C9 PCI-E capable, Rev 1 slot with 8x lanes fcs2 fcs5